Curve3dGetProjectedClosestPointTo(Curve3d,
Vector3d, Tolerance) Method
|
Retrieves the points on this curve closest to
the specified curve, and the point on the other curve closest to
this curve, when this curve is projected in the specified
direction.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public PointOnCurve3d[] GetProjectedClosestPointTo(
Curve3d curve3d,
Vector3d projectDirection,
Tolerance tolerance
)
Public Function GetProjectedClosestPointTo (
curve3d As Curve3d,
projectDirection As Vector3d,
tolerance As Tolerance
) As PointOnCurve3d()
public:
array<PointOnCurve3d^>^ GetProjectedClosestPointTo(
Curve3d^ curve3d,
Vector3d projectDirection,
Tolerance tolerance
)
member GetProjectedClosestPointTo :
curve3d : Curve3d *
projectDirection : Vector3d *
tolerance : Tolerance -> PointOnCurve3d[]
Parameters
- curve3d Curve3d
- [in] Curve to which the closest projected points are
calculated.
- projectDirection Vector3d
- [in] Projection direction.
- tolerance Tolerance
- [in] Geometric tolerance.
Return Value
PointOnCurve3d
Array of the projected closest points. The point with index 0 is
the closest point on this curve; the point with index 1 is the
closest point on the other curve.
See Also