GeometryText(Point3d, Vector3d, Vector3d, String, Boolean, TextStyle) Method

Introduces text into the vectorization context.

Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public abstract bool Text(
        Point3d position,
        Vector3d normal,
        Vector3d direction,
        string message,
        bool raw,
        TextStyle textStyle
)

Parameters

position  Point3d
[in] Position of the text string.
normal  Vector3d
[in] Normal vector of the text.
direction  Vector3d
[in] Baseline direction of the text.
message  String
[in] Text string.
raw  Boolean
[in] If true, escape sequences, such as %%P, are not converted to special characters.
textStyle  TextStyle
[in] TextStyle for the text.

Return Value

Boolean
true. This method also throws a corresponding exception if it fails.
See Also

©  Bricsys NV. All rights reserved.