NurbSurfaceEvaluate(Double,
Double, Int32, Point3d,
Vector3dCollection) Method
|
Evaluates the position on the NURBS surface at
the specified parameter value (u, v) and returns the evaluated
point.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public void Evaluate(
double dU,
double dV,
int derivDegree,
ref Point3d point,
ref Vector3dCollection derivatives
)
Public Sub Evaluate (
dU As Double,
dV As Double,
derivDegree As Integer,
ByRef point As Point3d,
ByRef derivatives As Vector3dCollection
)
public:
void Evaluate(
double dU,
double dV,
int derivDegree,
Point3d% point,
Vector3dCollection^% derivatives
)
member Evaluate :
dU : float *
dV : float *
derivDegree : int *
point : Point3d byref *
derivatives : Vector3dCollection byref -> unit
Parameters
- dU Double
- [in] U-direction parameter.
- dV Double
- [in] V-direction parameter.
- derivDegree Int32
-
- point Point3d
- [out] Receives the evaluated point.
- derivatives Vector3dCollection
- [out] Receives the first derivatives with respect to U and V
parameters.
Remarks
The derivatives collection indexes after the method
execution: * 0 - the first derivative with respect to u. * 1 - the
first derivative with respect to v. If the surface doesn't contain
any NURBS information, throws the eFail
exception. If the dU or dV value is out of range, throws the eOutOfRange exception. If this method is not
implemented for a specific modeler, throws the eNotImplementedYet exception.
See Also