DatabaseReadDwgFile(String,
FileOpenMode, Boolean, String, Boolean) Method
|
Reads the contents of the specified file into
this database object.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public void ReadDwgFile(
string fileName,
FileOpenMode mode,
bool allowCPConversion,
string password,
bool bPartialLoad
)
Public Sub ReadDwgFile (
fileName As String,
mode As FileOpenMode,
allowCPConversion As Boolean,
password As String,
bPartialLoad As Boolean
)
public:
void ReadDwgFile(
String^ fileName,
FileOpenMode mode,
bool allowCPConversion,
String^ password,
bool bPartialLoad
)
member ReadDwgFile :
fileName : string *
mode : FileOpenMode *
allowCPConversion : bool *
password : string *
bPartialLoad : bool -> unit
Parameters
- fileName String
- [in] Path to the file to read.
- mode FileOpenMode
- [in] Open mode.
- allowCPConversion Boolean
- [in] Flag that specifies whether codepage conversion should
occur silently.
- password String
- [in] Password for a file.
- bPartialLoad Boolean
- [in] Flag that specifies whether to perform partial loading of
a file.
Remarks
Pieces of the
drawing are read in only as needed. So, the drawing file is left
open until the database object is deleted. The method attempts to
open files with read access. The mode
argument describes how other applications can access the file when
the same file has already been opened. The allowCPConversion argument specifies whether to
automatically perform a default conversion from the drawing
codepage to the system codepage if corresponding files for
conversion are not available (which might cause loss of data). If
allowCPConversion is false, you are asked if conversion should be
performed, otherwise conversion is performed silently. If password
is NULL, the user is prompted for a password if required. This
method should be used only with a newly created database created
via its constructor's buildDefaultDrawing
argument set to false. In all other cases
memory leaks and fatal errors can occur. The bPartialLoad flag is optimal for use when you load
large drawings and plan to work only with a small part of a
drawing. This option can help save resources and time dedicated to
vectorizing the file content compared to a normal loading model
where all objects are loaded. Over time, some objects may be loaded
and vectorized as needed which can cause slight freezes while
working with a drawing.
See Also