EntityMoveGripPointsAtSubentityPaths
Method
|
Applies a vector offset to one or more grip
points exposed by the subentities of the object.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public virtual void MoveGripPointsAtSubentityPaths(
FullSubentityPath[] subPaths,
IntPtr[] appData,
Vector3d offset,
MoveGripPointsFlags bitFlags
)
Public Overridable Sub MoveGripPointsAtSubentityPaths (
subPaths As FullSubentityPath(),
appData As IntPtr(),
offset As Vector3d,
bitFlags As MoveGripPointsFlags
)
public:
virtual void MoveGripPointsAtSubentityPaths(
array<FullSubentityPath>^ subPaths,
array<IntPtr>^ appData,
Vector3d offset,
MoveGripPointsFlags bitFlags
)
abstract MoveGripPointsAtSubentityPaths :
subPaths : FullSubentityPath[] *
appData : IntPtr[] *
offset : Vector3d *
bitFlags : MoveGripPointsFlags -> unit
override MoveGripPointsAtSubentityPaths :
subPaths : FullSubentityPath[] *
appData : IntPtr[] *
offset : Vector3d *
bitFlags : MoveGripPointsFlags -> unit
Parameters
- subPaths FullSubentityPath
- [in] Array of full subentity paths.
- appData IntPtr
- [in] The array of pointers of OdDbGripData objects.
- offset Vector3d
- [in] The vector (in WCS coordinates) indicating the direction
and magnitude of the translation.
- bitFlags MoveGripPointsFlags
- [in] The bitmap of one or more flags specified by the
MoveGripPointsFlags enumeration.
See Also