EllipticalArc2dSet(Point2d,
Vector2d, Vector2d, Double, Double) Method
|
Sets the specified center, axes and radii for
this arc.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public void Set(
Point2d center,
Vector2d majorAxis,
Vector2d minorAxis,
double majorRadius,
double minorRadius
)
Public Sub Set (
center As Point2d,
majorAxis As Vector2d,
minorAxis As Vector2d,
majorRadius As Double,
minorRadius As Double
)
public:
void Set(
Point2d center,
Vector2d majorAxis,
Vector2d minorAxis,
double majorRadius,
double minorRadius
)
member Set :
center : Point2d *
majorAxis : Vector2d *
minorAxis : Vector2d *
majorRadius : float *
minorRadius : float -> unit
Parameters
- center Point2d
- [in] Center of this arc.
- majorAxis Vector2d
- [in] Vector that defines the major axis of this arc.
- minorAxis Vector2d
- [in] Vector that defines the minor axis of this arc.
- majorRadius Double
- [in] A point on the axis of symmetry.
- minorRadius Double
- [in] Axis of symmetry (rotation).
See Also