Window Class

Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Bricscad.WindowsWindow
        Bricscad.WindowsPaletteSet

Namespace: Bricscad.Windows
Assembly: BrxMgd (in BrxMgd.dll) Version: 24.0.1.0
Syntax
public class Window : DisposableWrapper, IWin32Window

The Window type exposes the following members.

Properties
  Name Description
Public property DeviceIndependentLocation  
Public property DeviceIndependentSize  
Public property Handle  
Public property Icon Obsolete.
Public property Location Obsolete.
Public property Size Obsolete.
Public property Text  
Public property Visible  
Public property WindowState  
Top
Methods
  Name Description
Public method Close  
Protected method DeleteUnmanagedObject
(Overrides DisposableWrapperDeleteUnmanagedObject)
Protected method Dispose(Boolean) Releases the unmanaged resources used by the Window and optionally releases the managed resources
(Overrides DisposableWrapperDispose(Boolean))
Public method Focus  
Public methodStatic member GetDeviceIndependentScale  
Public method GetIcon  
Public method GetLocation  
Public method GetSize  
Public method SetIcon  
Public method SetLocation  
Public method SetSize  
Top
See Also

©  Bricsys NV. All rights reserved.