RevolvedSurfaceSetRevolve
Method
|
Sets the provided parameters to create a
revolved surface.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public void SetRevolve(
Point3d axisPoint,
Vector3d axisDirection,
double revolveAngle,
RevolveOptions revolveOptions
)
Public Sub SetRevolve (
axisPoint As Point3d,
axisDirection As Vector3d,
revolveAngle As Double,
revolveOptions As RevolveOptions
)
public:
void SetRevolve(
Point3d axisPoint,
Vector3d axisDirection,
double revolveAngle,
RevolveOptions^ revolveOptions
)
member SetRevolve :
axisPoint : Point3d *
axisDirection : Vector3d *
revolveAngle : float *
revolveOptions : RevolveOptions -> unit
Parameters
- axisPoint Point3d
- [in] Point of the revolution axis.
- axisDirection Vector3d
- [in] Revolution axis' direction.
- revolveAngle Double
- [in] Angle of rotation (in radians).
- revolveOptions RevolveOptions
- [in] Options for revolving.
See Also