RevolveOptions Class

This class represents options for revolving. These options affect the shape of the revolved surface or revolved solid.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.DatabaseServicesRevolveOptions

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public class RevolveOptions : DisposableWrapper, 
        ICloneable

The RevolveOptions type exposes the following members.

Constructors
  Name Description
Public method RevolveOptions Default constructor for the RevolveOptions class.
Public method RevolveOptions(RevolveOptions) Copy constructor for the RevolveOptions class.
Protected method RevolveOptions(IntPtr, Boolean) Initializes a new instance of the RevolveOptions class
Top
Properties
  Name Description
Public property CloseToAxis Property that represents the 'close to axis' option. If this option is enabled and an open profile is revolved, the ends of the profile are extended to the axis of revolution before revolving.
Public property DraftAngle Property that represents the draft angle in radians. The profile narrows to this angle as it rotates around the axis.
Public property TwistAngle Property that represents the twist angle in radians. This is the angle by which the profile is twisted as it revolves around the axis.
Top
Methods
  Name Description
Public method CheckRevolveCurve Checks whether the entity is valid for the revolve operation.
Public method Clone Clones current options of the revolve.
Protected method DeleteUnmanagedObject
(Overrides DisposableWrapperDeleteUnmanagedObject)
Top
See Also

©  Bricsys NV. All rights reserved.