GripOverruleGetGripPoints(Entity,
Point3dCollection, IntegerCollection,
IntegerCollection) Method
|
Overrules the OdDbEntity::subGetGripPoints()
C++ method and calls it in the default implementation.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public virtual void GetGripPoints(
Entity entity,
Point3dCollection gripPoints,
IntegerCollection snapModes,
IntegerCollection geometryIds
)
Public Overridable Sub GetGripPoints (
entity As Entity,
gripPoints As Point3dCollection,
snapModes As IntegerCollection,
geometryIds As IntegerCollection
)
public:
virtual void GetGripPoints(
Entity^ entity,
Point3dCollection^ gripPoints,
IntegerCollection^ snapModes,
IntegerCollection^ geometryIds
)
abstract GetGripPoints :
entity : Entity *
gripPoints : Point3dCollection *
snapModes : IntegerCollection *
geometryIds : IntegerCollection -> unit
override GetGripPoints :
entity : Entity *
gripPoints : Point3dCollection *
snapModes : IntegerCollection *
geometryIds : IntegerCollection -> unit
Parameters
- entity Entity
- [in] Entity that this overrule applies to.
- gripPoints Point3dCollection
- [in/out] An existing collection to which the grip points should
be appended.
- snapModes IntegerCollection
- [in] Reserved for future use.
- geometryIds IntegerCollection
- [in] Reserved for future use.
See Also