GripOverrule Class

This class overrules a subset of grip-linked operations that an entity specifies. It is used as a base class for classes derived from the Entity class to change their behavior. Each default implementation calls the corresponding method of the target class.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.RuntimeRXObject
        Teigha.RuntimeOverrule
          Teigha.DatabaseServicesGripOverrule

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public abstract class GripOverrule : Overrule

The GripOverrule type exposes the following members.

Constructors
  Name Description
Protected method GripOverrule Initializes a new instance of the GripOverrule class
Top
Properties
  Name Description
Top
Methods
  Name Description
Public method GetGripPoints(Entity, Point3dCollection, IntegerCollection, IntegerCollection) Overrules the OdDbEntity::subGetGripPoints() C++ method and calls it in the default implementation.
Public method GetGripPoints(Entity, GripDataCollection, Double, Int32, Vector3d, GetGripPointsFlags) Overrules the OdDbEntity::subGetGripPoints() C++ method and calls it in the default implementation.
Public method GetStretchPoints Overrules the OdDbEntity::subGetStretchPoints() C++ method and calls it in the default implementation.
Public method MoveGripPointsAt(Entity, IntegerCollection, Vector3d) Overrules the OdDbEntity::subMoveGripPointsAt() C++ method and calls it in the default implementation.
Public method MoveGripPointsAt(Entity, GripDataCollection, Vector3d, MoveGripPointsFlags) Overrules the OdDbEntity::subMoveGripPointsAt() C++ method and calls it in the default implementation.
Public method MoveStretchPointsAt Overrules the OdDbEntity::subMoveStretchPointsAt() C++ method and calls it in the default implementation.
Public method OnGripStatusChanged Calls the OdDbEntity::subGripStatus in the default implementation.
Public method SetCustomFilter Enables the usage of the IsApplicable method to check whether an overrule is applied.
(Overrides OverruleSetCustomFilter)
Public method SetExtensionDictionaryEntryFilter Enables the usage of an extension dictionary lookup for checking whether an overrule is applied.
(Overrides OverruleSetExtensionDictionaryEntryFilter(String))
Public method SetIdFilter Enables the usage of ID lookups for checking whether an overrule is applied.
(Overrides OverruleSetIdFilter(ObjectId))
Public method SetNoFilter Disables the filter methods (SetCustomFilter, SetExtensionDictionaryEntryFilter, SetIdFilter, SetXDataFilter) and the IsApplicable() method for checking whether an overrule is applied.
(Overrides OverruleSetNoFilter)
Public method SetXDataFilter Enables the usage of xdata for checking whether an overrule is applied.
(Overrides OverruleSetXDataFilter(String))
Top
See Also

©  Bricsys NV. All rights reserved.