EntityColorCollection Class

Wraps OdCmEntityColorArray type. Represents a collection of EntityColor objects.
Inheritance Hierarchy
SystemObject
  Teigha.ColorsEntityColorCollection

Namespace: Teigha.Colors
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public sealed class EntityColorCollection : IList

The EntityColorCollection type exposes the following members.

Constructors
  Name Description
Public method EntityColorCollection Default constructor. Creates new EntityColorCollection object with capacity 10.
Public method EntityColorCollection(EntityColor) Builds a new instance of EntityColorCollection class using array of EntityColor objects.
Public method EntityColorCollection(Int32) Builds a new EntityColorCollection object with specific capacity.
Top
Properties
  Name Description
Public property Capacity Gets or sets the number of elements that the EntityColorCollection can contain.
Public property Count Gets the number of elements actually contained in the EntityColorCollection.
Public property IsFixedSize Gets a value indicating whether the EntityColorCollection has a fixed size.
Public property IsReadOnly Gets a value indicating whether the EntityColorCollection is read-only.
Public property IsSynchronized Gets a value indicating whether access to the EntityColorCollection is synchronized (thread safe).
Public property Item Gets or sets the element at the specified index in the EntityColorCollection.
Public property SyncRoot Gets an object that can be used to synchronize access to the EntityColorCollection.
Top
Methods
  Name Description
Public method Add Adds an EntityColor object to collection.
Public method AddRange Adds an array of EntityColor objects to the collection.
Public method Clear Removes all objects from the collection.
Public method Contains Determines whether the specified EntityColor object is a member of the collection.
Public method CopyTo Copies the entire contents of this EntityColorCollection to a compatible one-dimensional array, starting at the specified index of the target array.
Public method GetEnumerator Returns an enumerator for the entire EntityColorCollection.
Public method IndexOf Determines the index of a specific item in the collection.
Public method Insert Inserts an EntityColor object to the collection at the specified index.
Public method Remove Removes the first occurrence of a specific object from the EntityColorCollection
Public method RemoveAt Removes the EntityColorCollection item at the specified index.
Public method ToArray Creates an array of EntityColor objects from the EntityColorCollection.
Public method TrimToSize Sets the capacity to the actual number of elements in the EntityColorCollection.
Top
Fields
  Name Description
Public fieldStatic member DefaultSize Defaut size for creating a new EntityColorCollection object by default constructor EntityColorCollection().
Top
See Also

©  Bricsys NV. All rights reserved.