XrefGraph Class

This class represents the external reference tree of a database. This class uses XrefGraphNode objects to represent an xref database at each node.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.DatabaseServicesGraph
        Teigha.DatabaseServicesXrefGraph

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public class XrefGraph : Graph

The XrefGraph type exposes the following members.

Properties
  Name Description
Public property HostDrawing Property that represents the XrefGraphNode associated with the host drawing of this XrefGraph object.
Top
Methods
  Name Description
Public method GetXrefNode(Database) Returns the XrefGraphNode object corresponding to the specified parameter.
Public method GetXrefNode(Int32) Returns the XrefGraphNode object corresponding to the specified parameter.
Public method GetXrefNode(ObjectId) Returns the XrefGraphNode object corresponding to the specified parameter.
Public method GetXrefNode(String) Returns the XrefGraphNode object corresponding to the specified parameter.
Public method MarkUnresolvedTrees Marks the unresolved xrefs in this XrefGraph object, and their nested xrefs, with the kUnresTree flag.
Top
See Also

©  Bricsys NV. All rights reserved.