NurbSurfaceSet(Int32,
Int32, Int32, Int32, Int32,
Int32, Point3dCollection,
DoubleCollection, KnotCollection,
KnotCollection, Tolerance) Method
|
Sets properties for this NURBS surface.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public void Set(
int degreeU,
int degreeV,
int propsInU,
int propsInV,
int numControlPointsInU,
int numControlPointsInV,
Point3dCollection controlPoints,
DoubleCollection weights,
KnotCollection knotsInU,
KnotCollection knotsInV,
Tolerance tolerance
)
Public Sub Set (
degreeU As Integer,
degreeV As Integer,
propsInU As Integer,
propsInV As Integer,
numControlPointsInU As Integer,
numControlPointsInV As Integer,
controlPoints As Point3dCollection,
weights As DoubleCollection,
knotsInU As KnotCollection,
knotsInV As KnotCollection,
tolerance As Tolerance
)
public:
void Set(
int degreeU,
int degreeV,
int propsInU,
int propsInV,
int numControlPointsInU,
int numControlPointsInV,
Point3dCollection^ controlPoints,
DoubleCollection^ weights,
KnotCollection^ knotsInU,
KnotCollection^ knotsInV,
Tolerance tolerance
)
member Set :
degreeU : int *
degreeV : int *
propsInU : int *
propsInV : int *
numControlPointsInU : int *
numControlPointsInV : int *
controlPoints : Point3dCollection *
weights : DoubleCollection *
knotsInU : KnotCollection *
knotsInV : KnotCollection *
tolerance : Tolerance -> unit
Parameters
- degreeU Int32
- [in] Degree in the U direction.
- degreeV Int32
- [in] Degree in the V direction.
- propsInU Int32
- [in] Properties in the U direction.
- propsInV Int32
-
- numControlPointsInU Int32
-
- numControlPointsInV Int32
-
- controlPoints Point3dCollection
- [in] Array of 3D control points.
- weights DoubleCollection
- [in] Array of weights.
- knotsInU KnotCollection
- [in] Knot vector in the U direction.
- knotsInV KnotCollection
- [in] Knot vector in the V direction.
- tolerance Tolerance
- [in] Knot vector in the V direction.
See Also