NurbSurface Class

This class represents non-uniform, rational B-Spline (NURBS) surfaces. For more information, see Working with NURBS Surfaces.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.GeometryEntity3d
        Teigha.GeometrySurface
          Teigha.GeometryNurbSurface

Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public sealed class NurbSurface : Surface

The NurbSurface type exposes the following members.

Constructors
  Name Description
Public method NurbSurface Default constructor for the NurbSurface class. Creates a default corresponding C++ object with no actual data stored in the object.
Public method NurbSurface(Int32, Int32, Int32, Int32, Int32, Int32, Point3dCollection, DoubleCollection, KnotCollection, KnotCollection) Constructor for the NurbSurface class. Constructs a NURBS surface defined by input data. propsInU and propertiesInV utilize OdGe::NurbSurfaceProperties values.
Public method NurbSurface(Int32, Int32, Int32, Int32, Int32, Int32, Point3dCollection, DoubleCollection, KnotCollection, KnotCollection, Tolerance) Constructor for the NurbSurface class. Constructs a NURBS surface defined by input data. propsInU and propertiesInV utilize OdGe::NurbSurfaceProperties values.
Top
Properties
  Name Description
Public property ControlPoints  
Public property DegreeInU  
Public property DegreeInV  
Public property IsPeriodicInU  
Public property IsPeriodicInV  
Public property IsRationalInU  
Public property IsRationalInV  
Public property NumControlPointsInU  
Public property NumControlPointsInV  
Public property NumKnotsInU  
Public property NumKnotsInV  
Public property PeriodicInU  
Public property PeriodicInV  
Public property SingularityInU  
Public property SingularityInV  
Public property UKnots  
Public property VKnots  
Public property Weights  
Top
Methods
  Name Description
Public methodStatic member Create Creates an object based on the passed pointer and returns a handle to the created object.
Public method GetDefinition Returns the NURBS surface definition for this NURBS surface. NURBS surface definition contains information about: * Degree in U and V * Properties in U and V * Count of control points in U and V * Control points * Weight values * Knots in U and V
Public method Set(Int32, Int32, Int32, Int32, Int32, Int32, Point3dCollection, DoubleCollection, KnotCollection, KnotCollection) Sets properties for this NURBS surface.
Public method Set(Int32, Int32, Int32, Int32, Int32, Int32, Point3dCollection, DoubleCollection, KnotCollection, KnotCollection, Tolerance) Sets properties for this NURBS surface.
Top
See Also

©  Bricsys NV. All rights reserved.