FieldEvaluatorCompile Method

Compiles a field when the field code is changed.

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public abstract void Compile(
        Field pField,
        Database pDb,
        FieldResult result
)

Parameters

pField  Field
[in] Field to compile.
pDb  Database
[in] Database pointer.
result  FieldResult
[in] Field result object to set the compilation status.
Remarks
The evaluator can do any parsing of the field code here and store the parsed data in the field. This method is called only when the field code is changed, unlike evaluate(), which is called whenever the field needs to be evaluated.
See Also

©  Bricsys NV. All rights reserved.