EllipticalCone Constructor

Overload List
  Name Description
Public method EllipticalCone Default constructor for the EllipticalCone class. Creates a default corresponding C++ object with cosine angle equal to cos(OdaPI/4.0), sine angle equal to -sin(OdaPI/4.0), base origin at the origin of the world coordinate system, 1.0 for major and minor radii, and OdGeVector3d::kYAxis for the axis of symmetry.
Public method EllipticalCone(Double, Double, Point3d, Double, Double, Vector3d) Constructor for the EllipticalCone class. Creates an object with specified cosine and sine angles, base origin, minor and major radii, and axis of symmetry.
Public method EllipticalCone(Double, Double, Point3d, Double, Double, Vector3d, Vector3d, Interval, Double, Double) Constructor for the EllipticalCone class. Creates an object with specified cosine and sine angles, base origin, minor and major radii, axis of symmetry, height interval, and start and end angles.
Top
See Also