EllipticalCone(Double, Double, Point3d, Double,
Double, Vector3d) Constructor
|
Constructor for the EllipticalCone class.
Creates an object with specified cosine and sine angles, base
origin, minor and major radii, and axis of symmetry.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public EllipticalCone(
double cosineAngle,
double sineAngle,
Point3d baseOrigin,
double minorRadius,
double majorRadius,
Vector3d axisOfSymmetry
)
Public Sub New (
cosineAngle As Double,
sineAngle As Double,
baseOrigin As Point3d,
minorRadius As Double,
majorRadius As Double,
axisOfSymmetry As Vector3d
)
public:
EllipticalCone(
double cosineAngle,
double sineAngle,
Point3d baseOrigin,
double minorRadius,
double majorRadius,
Vector3d axisOfSymmetry
)
new :
cosineAngle : float *
sineAngle : float *
baseOrigin : Point3d *
minorRadius : float *
majorRadius : float *
axisOfSymmetry : Vector3d -> EllipticalCone
Parameters
- cosineAngle Double
- [in] The cosine of the angle between the generating line
passing through the major axis and the axis of symmetry.
- sineAngle Double
- [in] The sine of the angle between the generating line passing
through the major axis and the axis of symmetry.
- baseOrigin Point3d
-
- minorRadius Double
- [in] The minor radius of this elliptical cone.
- majorRadius Double
- [in] The major radius of this elliptical cone.
- axisOfSymmetry Vector3d
- [in] Axis of symmetry (rotation).
See Also