EllipticalCone(Double, Double, Point3d, Double,
Double, Vector3d, Vector3d, Interval, Double, Double)
Constructor
|
Constructor for the EllipticalCone class.
Creates an object with specified cosine and sine angles, base
origin, minor and major radii, axis of symmetry, height interval,
and start and end angles.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public EllipticalCone(
double cosineAngle,
double sineAngle,
Point3d baseOrigin,
double minorRadius,
double majorRadius,
Vector3d axisOfSymmetry,
Vector3d majorAxis,
Interval height,
double startAngle,
double endAngle
)
Public Sub New (
cosineAngle As Double,
sineAngle As Double,
baseOrigin As Point3d,
minorRadius As Double,
majorRadius As Double,
axisOfSymmetry As Vector3d,
majorAxis As Vector3d,
height As Interval,
startAngle As Double,
endAngle As Double
)
public:
EllipticalCone(
double cosineAngle,
double sineAngle,
Point3d baseOrigin,
double minorRadius,
double majorRadius,
Vector3d axisOfSymmetry,
Vector3d majorAxis,
Interval^ height,
double startAngle,
double endAngle
)
new :
cosineAngle : float *
sineAngle : float *
baseOrigin : Point3d *
minorRadius : float *
majorRadius : float *
axisOfSymmetry : Vector3d *
majorAxis : Vector3d *
height : Interval *
startAngle : float *
endAngle : float -> EllipticalCone
Parameters
- cosineAngle Double
- [in] The cosine of the angle between the generating line
passing through the major axis and the axis of symmetry.
- sineAngle Double
- [in] The sine of the angle between the generating line passing
through the major axis and the axis of symmetry.
- baseOrigin Point3d
-
- minorRadius Double
- [in] The minor radius of this elliptical cone.
- majorRadius Double
- [in] The major radius of this elliptical cone.
- axisOfSymmetry Vector3d
- [in] Axis of symmetry (rotation).
- majorAxis Vector3d
- [in] Major axis of this elliptical cone.
- height Interval
- [in] Height interval of this elliptical cone.
- startAngle Double
- [in] Start angle of this elliptical cone (angle offset from
which elliptical cone segments are drawn).
- endAngle Double
- [in] End angle of this elliptical cone (angle offset to which
elliptical cone segments are drawn).
See Also