NurbCurve3dSetFitData(KnotCollection,
Point3dCollection, Vector3d, Vector3d,
Tolerance, Boolean) Method
|
Sets the fit data for this spline.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public void SetFitData(
KnotCollection fitKnots,
Point3dCollection fitPoints,
Vector3d startTangent,
Vector3d endTangent,
Tolerance fitTolerance,
bool periodic
)
Public Sub SetFitData (
fitKnots As KnotCollection,
fitPoints As Point3dCollection,
startTangent As Vector3d,
endTangent As Vector3d,
fitTolerance As Tolerance,
periodic As Boolean
)
public:
void SetFitData(
KnotCollection^ fitKnots,
Point3dCollection^ fitPoints,
Vector3d startTangent,
Vector3d endTangent,
Tolerance fitTolerance,
bool periodic
)
member SetFitData :
fitKnots : KnotCollection *
fitPoints : Point3dCollection *
startTangent : Vector3d *
endTangent : Vector3d *
fitTolerance : Tolerance *
periodic : bool -> unit
Parameters
- fitKnots KnotCollection
- [in] Fit knots.
- fitPoints Point3dCollection
- [in] Interpolation points.
- startTangent Vector3d
- [in] Start tangent.
- endTangent Vector3d
- [in] End tangent.
- fitTolerance Tolerance
- [in] Geometric tolerance.
- periodic Boolean
- [in] Flag that specifies whether to make the curve periodic (a
closed curve).
Remarks
Recomputes the
spline from the input fit points and start and end tangents. The
first parameter specifies the knot vector for the new spline. If
fitTolerance is not 0, the constructed spline may not pass through
the fit points, but the maximum distance from any fit point to the
constructed spline is no greater than fitTolerance.
See Also