LineSegment3d(Point3d, Vector3d)
Constructor
|
Constructor for the LineSegment3d class.
Creates a line segment with a point and vector.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public LineSegment3d(
Point3d point1,
Vector3d vector
)
Public Sub New (
point1 As Point3d,
vector As Vector3d
)
public:
LineSegment3d(
Point3d point1,
Vector3d vector
)
new :
point1 : Point3d *
vector : Vector3d -> LineSegment3d
Parameters
- point1 Point3d
- [in] Start of the line segment.
- vector Vector3d
- [in] Defines the direction of the line and the second point of
the line.
See Also