LineSegment3d Class

This class represents line segments in 3D space. For more information, see Working with Lines.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.GeometryEntity3d
        Teigha.GeometryCurve3d
          Teigha.GeometryLinearEntity3d
            Teigha.GeometryLineSegment3d

Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public sealed class LineSegment3d : LinearEntity3d

The LineSegment3d type exposes the following members.

Constructors
  Name Description
Public method LineSegment3d Default constructor for the LineSegment3d class. Creates a default corresponding C++ object with the lower parameter set to 0.0 and the upper parameter set to 1.0.
Public method LineSegment3d(Point3d, Point3d) Constructor for the LineSegment3d class. Creates a line segment with two specified points.
Public method LineSegment3d(Point3d, Vector3d) Constructor for the LineSegment3d class. Creates a line segment with a point and vector.
Top
Properties
  Name Description
Public property EndPoint  
Public property Length  
Public property MidPoint  
Public property StartPoint  
Top
Methods
  Name Description
Public method BaryComb  
Public methodStatic member Create Creates an object based on the passed pointer and returns a handle to the created object.
Public method GetBisector Returns the unbounded perpendicular bisecting plane of this line segment.
Public method Set(Point3d, Point3d) Specifies points for this line segment.
Public method Set(Point3d, Vector3d) Specifies a point and vector for this line segment.
Public method Set(Curve3d, Point3d, Double) Specifies the parameters for this line according to the arguments.
Public method Set(Curve3d, Curve3d, Double, Double) Specifies the parameters for this line according to the arguments.
Top
See Also

©  Bricsys NV. All rights reserved.