NurbSurface(Int32, Int32, Int32,
Int32, Int32, Int32,
Point3dCollection, DoubleCollection,
KnotCollection, KnotCollection) Constructor
|
Constructor for the NurbSurface class.
Constructs a NURBS surface defined by input data. propsInU and
propertiesInV utilize OdGe::NurbSurfaceProperties values.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public NurbSurface(
int degreeU,
int degreeV,
int propsInU,
int propertiesInV,
int numberControlPointsInU,
int numberControlPointsInV,
Point3dCollection controlPoints,
DoubleCollection weights,
KnotCollection knotsInU,
KnotCollection knotsInV
)
Public Sub New (
degreeU As Integer,
degreeV As Integer,
propsInU As Integer,
propertiesInV As Integer,
numberControlPointsInU As Integer,
numberControlPointsInV As Integer,
controlPoints As Point3dCollection,
weights As DoubleCollection,
knotsInU As KnotCollection,
knotsInV As KnotCollection
)
public:
NurbSurface(
int degreeU,
int degreeV,
int propsInU,
int propertiesInV,
int numberControlPointsInU,
int numberControlPointsInV,
Point3dCollection^ controlPoints,
DoubleCollection^ weights,
KnotCollection^ knotsInU,
KnotCollection^ knotsInV
)
new :
degreeU : int *
degreeV : int *
propsInU : int *
propertiesInV : int *
numberControlPointsInU : int *
numberControlPointsInV : int *
controlPoints : Point3dCollection *
weights : DoubleCollection *
knotsInU : KnotCollection *
knotsInV : KnotCollection -> NurbSurface
Parameters
- degreeU Int32
- [in] Degree in the U direction.
- degreeV Int32
- [in] Degree in the V direction.
- propsInU Int32
- [in] Properties in the U direction.
- propertiesInV Int32
- [in] Properties in the V direction.
- numberControlPointsInU Int32
- [in] Number of control points in the U direction.
- numberControlPointsInV Int32
- [in] Number of control points in the V direction.
- controlPoints Point3dCollection
- [in] Array of 3D control points.
- weights DoubleCollection
- [in] Array of weights.
- knotsInU KnotCollection
- [in] Knot vector in the U direction.
- knotsInV KnotCollection
- [in] Knot vector in the V direction.
See Also