Spline(Point3d, Vector3d, Vector3d,
Double, Double, Double) Constructor
|
Constructor for the Spline class.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public Spline(
Point3d center,
Vector3d unitNormal,
Vector3d majorAxis,
double radiusRatio,
double startAngle,
double endAngle
)
Public Sub New (
center As Point3d,
unitNormal As Vector3d,
majorAxis As Vector3d,
radiusRatio As Double,
startAngle As Double,
endAngle As Double
)
public:
Spline(
Point3d center,
Vector3d unitNormal,
Vector3d majorAxis,
double radiusRatio,
double startAngle,
double endAngle
)
new :
center : Point3d *
unitNormal : Vector3d *
majorAxis : Vector3d *
radiusRatio : float *
startAngle : float *
endAngle : float -> Spline
Parameters
- center Point3d
- [in] Center point of the elliptical arc.
- unitNormal Vector3d
- [in] Normal to the elliptical arc.
- majorAxis Vector3d
- [in] Major axis measured from the center point to the ellipse
start point.
- radiusRatio Double
- [in] Ratio of minor to major axis length.
- startAngle Double
- [in] Angle of start point (in radians).
- endAngle Double
- [in] Angle of end point (in radians).
See Also