Tapers the specified faces about the specified
base point and draft vector for a specified draft angle.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public virtual void TaperFaces(
SubentityId[] subentityIds,
Point3d basePoint,
Vector3d draftVector,
double draftAngle
)
Public Overridable Sub TaperFaces (
subentityIds As SubentityId(),
basePoint As Point3d,
draftVector As Vector3d,
draftAngle As Double
)
public:
virtual void TaperFaces(
array<SubentityId>^ subentityIds,
Point3d basePoint,
Vector3d draftVector,
double draftAngle
)
abstract TaperFaces :
subentityIds : SubentityId[] *
basePoint : Point3d *
draftVector : Vector3d *
draftAngle : float -> unit
override TaperFaces :
subentityIds : SubentityId[] *
basePoint : Point3d *
draftVector : Vector3d *
draftAngle : float -> unit
Parameters
- subentityIds SubentityId
- [in] Face's subentity ID in the solid.
- basePoint Point3d
- [in] Base point of the draft plane.
- draftVector Vector3d
-
- draftAngle Double
- [in] Draft angle in radians.
Remarks
The base point and
the draft vector define a draft plane about which the faces are
tapered. If the face is in the draft plane, it is not modified.
Tapering faces can cause the solid to become invalid in some cases.
This method is implemented only for the Spatial modeler.
See Also