TableSetGridColor(Int32,
Int32, GridLineType, Color) Method
|
Sets the grid color of the cell, row or
column. Use a valid row index and pass the column index '-1' to get
the row grid line color. Use a valid column index and pass the row
index '-1' to get the column grid line color.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public virtual void SetGridColor(
int row,
int column,
GridLineType gridLineType,
Color color
)
Public Overridable Sub SetGridColor (
row As Integer,
column As Integer,
gridLineType As GridLineType,
color As Color
)
public:
virtual void SetGridColor(
int row,
int column,
GridLineType gridLineType,
Color^ color
)
abstract SetGridColor :
row : int *
column : int *
gridLineType : GridLineType *
color : Color -> unit
override SetGridColor :
row : int *
column : int *
gridLineType : GridLineType *
color : Color -> unit
Parameters
- row Int32
- [in] Row index.
- column Int32
- [in] Column index.
- gridLineType GridLineType
- [in] Gridline type.
- color Color
- [in] Grid color.
Remarks
The gridlineType
parameter must have one of the following values:
NameValueDescriptionHorizontalTop 0x01 Top or
bottom horizontal table's grid line, depending on the flow
direction of the table rows (down or up). HorizontalInside 0x02 All
horizontal grid lines, excluding the bottom and top lines.
HorizontalBottom 0x04 Bottom or top horizontal table's grid line,
depending on the flow direction of the table rows (down or up).
VerticalLeft 0x08 The grid line at the left of the table.
VerticalInside 0x10 All vertical grid lines, excluding the left and
right lines. VerticalRight 0x20 The grid line at the right of the
table.
See Also