EllipticalArc3dIntersectWith(LinearEntity3d,
Tolerance) Method
|
Calculates intersection points with the
specified linear entity according to a geometric tolerance.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public Point3d[] IntersectWith(
LinearEntity3d line,
Tolerance tolerance
)
Public Function IntersectWith (
line As LinearEntity3d,
tolerance As Tolerance
) As Point3d()
public:
array<Point3d>^ IntersectWith(
LinearEntity3d^ line,
Tolerance tolerance
)
member IntersectWith :
line : LinearEntity3d *
tolerance : Tolerance -> Point3d[]
Parameters
- line LinearEntity3d
-
- tolerance Tolerance
- [in] Geometric tolerance.
Return Value
Point3d
If the method fails or there are no intersection points, this
method returns nullptr. The returned array consists of two
elements. The first element corresponds to the first intersection
point (if it exists), and the second element corresponds to the
second intersection point (if it exists).
See Also