NurbSurfaceEvaluate(Double,
Double, Point3d, Vector3d,
Vector3d) Method
|
Evaluates the position on the NURBS surface at
the specified parameter value (u, v) and returns the evaluated
point.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public void Evaluate(
double dU,
double dV,
ref Point3d pos,
ref Vector3d uDeriv,
ref Vector3d vDeriv
)
Public Sub Evaluate (
dU As Double,
dV As Double,
ByRef pos As Point3d,
ByRef uDeriv As Vector3d,
ByRef vDeriv As Vector3d
)
public:
void Evaluate(
double dU,
double dV,
Point3d% pos,
Vector3d% uDeriv,
Vector3d% vDeriv
)
member Evaluate :
dU : float *
dV : float *
pos : Point3d byref *
uDeriv : Vector3d byref *
vDeriv : Vector3d byref -> unit
Parameters
- dU Double
- [in] U-direction parameter.
- dV Double
- [in] V-direction parameter.
- pos Point3d
- [out] Receives the evaluated point.
- uDeriv Vector3d
- [out] Receives the first derivative with respect to u
parameters.
- vDeriv Vector3d
- [out] Receives the first derivative with respect to v
parameters.
Remarks
If the surface
doesn't contain any NURBS information, throws the eFail exception. If the dU
or dV value is out of range, throws the
eOutOfRange exception. If this method is
not implemented for a specific modeler, throws the eNotImplementedYet exception.
See Also