Curve3dIsPlanar(Plane, Tolerance) Method
|
Checks whether this curve is planar within a
specified tolerance. If the curve is a line, this function returns
an arbitrary plane that contains the line. The plane parameter
contains meaningful data only if this function returns a value of
true.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public bool IsPlanar(
out Plane plane,
Tolerance tolerance
)
Public Function IsPlanar (
<OutAttribute> ByRef plane As Plane,
tolerance As Tolerance
) As Boolean
public:
bool IsPlanar(
[OutAttribute] Plane^% plane,
Tolerance tolerance
)
member IsPlanar :
plane : Plane byref *
tolerance : Tolerance -> bool
Parameters
- plane Plane
- [out] Plane on which this curve lies if it is planar.
- tolerance Tolerance
- [in] Geometric tolerance.
Return Value
Boolean
true if this curve is planar,
false otherwise.
See Also