DatabaseDeepCloneObjects Method
|
Deep clones a set of objects and appends the
clones to the specified owner object.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public void DeepCloneObjects(
ObjectIdCollection identifiers,
ObjectId id,
IdMapping mapping,
bool deferTranslation
)
Public Sub DeepCloneObjects (
identifiers As ObjectIdCollection,
id As ObjectId,
mapping As IdMapping,
deferTranslation As Boolean
)
public:
void DeepCloneObjects(
ObjectIdCollection^ identifiers,
ObjectId id,
IdMapping^ mapping,
bool deferTranslation
)
member DeepCloneObjects :
identifiers : ObjectIdCollection *
id : ObjectId *
mapping : IdMapping *
deferTranslation : bool -> unit
Parameters
- identifiers ObjectIdCollection
- [in] Array of object IDs of the objects to be cloned.
- id ObjectId
- [in] Object ID of the owner object.
- mapping IdMapping
- [in/out] ID map.
- deferTranslation Boolean
- [in] Defer translation.
Remarks
idMap associates
the object IDs of the original objects with the object IDs of the
newly created clones. When cloning objects with different owner
IDs, a separate call to this method is required for each ownerId.
In this case, all but the final call to this method should be made
with deferXlation == true. This defers translation until all
objects have been cloned. A deep clone is a clone of the specified
objects and everything they own.
See Also