Hlr
|
The HlrEngine type exposes the following members.
Name | Description | |
---|---|---|
![]() |
HlrEngine(Int32) | Initializes a new instance of the HlrEngine class |
![]() |
HlrEngine(ObjectId, Int32) | Initializes a new instance of the HlrEngine class |
![]() |
HlrEngine(Viewport, Int32) | Initializes a new instance of the HlrEngine class |
![]() |
HlrEngine(Point3d, Vector3d, Int32) | Initializes a new instance of the HlrEngine class |
Name | Description | |
---|---|---|
![]() |
AutoDelete | (Inherited from DisposableWrapper) |
![]() ![]() |
CurrentProgress | |
![]() |
IsDisposed | (Inherited from DisposableWrapper) |
![]() |
Progress | |
![]() |
UnmanagedObject | (Inherited from DisposableWrapper) |
Name | Description | |
---|---|---|
![]() ![]() |
CleanHlrCache | |
![]() ![]() |
CleanHlrCache(Entity, Viewport) | |
![]() ![]() |
CleanHlrCache(Entity, Point3d, Vector3d) | |
![]() |
CreateObjRef | Creates an object that contains all the relevant information
required to generate a proxy used to communicate with a remote
object. (Inherited from MarshalByRefObject) |
![]() |
DeleteUnmanagedObject | (Overrides DisposableWrapperDeleteUnmanagedObject) |
![]() |
Dispose | (Inherited from DisposableWrapper) |
![]() |
Dispose(Boolean) | (Inherited from DisposableWrapper) |
![]() |
Equals | (Inherited from DisposableWrapper) |
![]() |
Finalize | (Inherited from DisposableWrapper) |
![]() |
GetHashCode | (Inherited from DisposableWrapper) |
![]() |
GetLifetimeService | Retrieves the current lifetime service object that controls the
lifetime policy for this instance. (Inherited from MarshalByRefObject) |
![]() |
GetType | Gets the Type of the current
instance. (Inherited from Object) |
![]() |
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime
policy for this instance. (Inherited from MarshalByRefObject) |
![]() |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object) |
![]() |
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject
object. (Inherited from MarshalByRefObject) |
![]() |
Run | |
![]() |
ToString | Returns a string that represents the current object. (Inherited from Object) |
© Bricsys NV. All rights reserved. |