Curve2dGetNormalPoint(Point2d,
Tolerance) Method
|
Retrieves the point on this curve where normal
extends through the passed point within the specified
tolerance.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public PointOnCurve2d GetNormalPoint(
Point2d point,
Tolerance tolerance
)
Public Function GetNormalPoint (
point As Point2d,
tolerance As Tolerance
) As PointOnCurve2d
public:
PointOnCurve2d^ GetNormalPoint(
Point2d point,
Tolerance tolerance
)
member GetNormalPoint :
point : Point2d *
tolerance : Tolerance -> PointOnCurve2d
Parameters
- point Point2d
- [in] Point for which corresponding point on this curve is
retrieved.
- tolerance Tolerance
- [in] Geometric tolerance.
Return Value
PointOnCurve2d
Point whose normal passes through the input point.
See Also