EntityBoundingBoxIntersectWith(Entity, Intersect, Plane, Point3dCollection, IntPtr, IntPtr) Method

Projects the bounding box edges of this entity and the passed entity on the projection plane, calculates the bounding box for this entity, and then finds the intersection points and projects intersections back to the bounding box edge of this entity.

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public void BoundingBoxIntersectWith(
        Entity entityPointer,
        Intersect intersectType,
        Plane projectionPlane,
        Point3dCollection points,
        IntPtr thisGraphicSystemMarker,
        IntPtr otherGraphicSystemMarker
)

Parameters

entityPointer  Entity
[in] Entity with which to calculate intersections.
intersectType  Intersect
[in] Intersection type.
projectionPlane  Plane
[in] Projection plane.
points  Point3dCollection
[out] Receives an array of intersection points (in WCS coordinates).
thisGraphicSystemMarker  IntPtr
[in] GS marker of the subentity of this entity that is involved in the intersection operation. May be 0 if not applicable.
otherGraphicSystemMarker  IntPtr
[in] GS marker of the subentity of the passed entity that is involved in the intersection operation. May be 0 if not applicable.
See Also

©  Bricsys NV. All rights reserved.