Sphere(Double, Point3d, Vector3d, Vector3d, Double, Double, Double, Double) Constructor

Constructor for the Sphere class. Creates a sphere with the specified parameters.

Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public Sphere(
        double radius,
        Point3d center,
        Vector3d northAxis,
        Vector3d referenceAxis,
        double startAngleU,
        double endAngleU,
        double startAngleV,
        double endAngleV
)

Parameters

radius  Double
[in] The radius of this sphere.
center  Point3d
[in] The origin of the this sphere.
northAxis  Vector3d
 
referenceAxis  Vector3d
[in] The direction to the prime meridian.
startAngleU  Double
[in] Starting longitude which is defined by a U parameter. To create a closed sphere, set this parameter to -OdaPI/2 and endAngleU to OdaPI/2.
endAngleU  Double
[in] Ending longitude which is defined by a U parameter. To create a closed sphere, set this parameter to OdaPI/2 and startAngleU to -OdaPI/2.
startAngleV  Double
[in] tarting latitude which is defined by a V parameter. To create a closed sphere, set this parameter to -OdaPI and endAngleV to OdaPI.
endAngleV  Double
[in] Ending latitude which is defined by a V parameter. To create a closed sphere, set this parameter to -OdaPI and endAngleV to OdaPI.
See Also

©  Bricsys NV. All rights reserved.