Sphere Class

Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.GeometryEntity3d
        Teigha.GeometrySurface
          Teigha.GeometrySphere

Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public sealed class Sphere : Surface

The Sphere type exposes the following members.

Constructors
  Name Description
Public method Sphere Default constructor for the Sphere class. Creates a default corresponding C++ which is sphere that is located at the origin of world coordinates and with 1.0 radius.
Public method Sphere(Double, Point3d) Constructor for the Sphere class. Creates a sphere with the specified origin and radius.
Public method Sphere(Double, Point3d, Vector3d, Vector3d, Double, Double, Double, Double) Constructor for the Sphere class. Creates a sphere with the specified parameters.
Top
Properties
  Name Description
Public property Center  
Public property IsOuterNormal  
Public property NorthAxis  
Public property NorthPole  
Public property Radius  
Public property ReferenceAxis  
Public property SouthPole  
Top
Methods
  Name Description
Public methodStatic member Create Creates an object based on the passed pointer and returns a handle to the created object.
Public method GetAnglesInU Returns angles for the u parameter.
Public method GetAnglesInV Returns angles for the v parameter.
Public method IntersectWith(LinearEntity3d) Calculates intersection points with the specified linear entity.
Public method IntersectWith(LinearEntity3d, Tolerance) Calculates intersection points with the specified linear entity according to a geometric tolerance.
Public method IsClosed Checks whether the equator of this sphere is a full circle.
Public method IsClosed(Tolerance) Checks whether the equator of this sphere is a full circle according to the specified tolerance.
Public method Set(Double, Point3d) Sets the parameters for this sphere according to the arguments.
Public method Set(Double, Point3d, Vector3d, Vector3d, Double, Double, Double, Double) Sets the parameters for this sphere according to the arguments.
Public method SetAnglesInU Sets the starting and ending longitudes.
Public method SetAnglesInV Sets the starting and ending latitudes.
Top
See Also

©  Bricsys NV. All rights reserved.