GraphNode Class

Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.DatabaseServicesGraphNode
        Teigha.DatabaseServicesXrefGraphNode

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public class GraphNode : DisposableWrapper

The GraphNode type exposes the following members.

Constructors
  Name Description
Public method GraphNode Initializes a new instance of the GraphNode class
Protected method GraphNode(IntPtr, Boolean) Initializes a new instance of the GraphNode class
Top
Properties
  Name Description
Public property Data  
Public property IsCycleNode  
Public property NextCycleNode  
Public property NumCycleIn  
Public property NumCycleOut  
Public property NumIn  
Public property NumOut  
Public property Owner  
Top
Methods
  Name Description
Public method AddRefTo  
Public method Clear  
Public method CycleIn  
Public method CycleOut  
Protected method DeleteUnmanagedObject
(Overrides DisposableWrapperDeleteUnmanagedObject)
Public method DisconnectAll  
Public method In  
Public method IsMarkedAs  
Public method MarkAs  
Public method MarkTree  
Public method Out  
Public method RemoveRefTo  
Public method SetEdgeGrowthRate  
Top
See Also

©  Bricsys NV. All rights reserved.