XrefGraphNode Class

This class represents an xref database. An XrefGraph object represents the relationship between a host drawing, its externally referenced drawings, and any nested xref drawings. Within a graph, any database or xref BlockTableRecord is represented by the XrefGraphNode class. Relationships between databases are represented by an edge in the graph. These relationships can be input (databases that are referencing this node) and output (databases that are referenced by this node). The relationships can be obtained using the GraphNode.in(idx) and GraphNode.out(idx) calls.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.DatabaseServicesGraphNode
        Teigha.DatabaseServicesXrefGraphNode

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public class XrefGraphNode : GraphNode

The XrefGraphNode type exposes the following members.

Properties
  Name Description
Public property BlockTableRecordId Property that represents the object identifier of the BlockTableRecord associated with this XrefGraphNode object.
Public property Database Property that represents the database relevant to this XrefGraphNode object.
Public property IsNested Property that indicates whether the XrefGraphNode represents an xref that is not directly referenced by the host drawing.
Public property Name Property that represents the name associated with this XrefGraphNode object.
Public property XrefNotificationStatus Property that represents the xref notification status for this XrefGraphNode object.
Public property XrefStatus Property that represents the status for this XrefGraphNode object.
Top
Methods
  Name Description
Top
See Also

©  Bricsys NV. All rights reserved.