ObjectOverruleDeepClone
Method
|
Calls the corresponding
OdDbObjectOverrule::deepClone() method.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public virtual DBObject DeepClone(
DBObject dbObject,
DBObject ownerObject,
IdMapping idMap,
bool isPrimary
)
Public Overridable Function DeepClone (
dbObject As DBObject,
ownerObject As DBObject,
idMap As IdMapping,
isPrimary As Boolean
) As DBObject
public:
virtual DBObject^ DeepClone(
DBObject^ dbObject,
DBObject^ ownerObject,
IdMapping^ idMap,
bool isPrimary
)
abstract DeepClone :
dbObject : DBObject *
ownerObject : DBObject *
idMap : IdMapping *
isPrimary : bool -> DBObject
override DeepClone :
dbObject : DBObject *
ownerObject : DBObject *
idMap : IdMapping *
isPrimary : bool -> DBObject
Parameters
- dbObject DBObject
- [in] Database object to which the overrule is applied.
- ownerObject DBObject
- [in] Database object to which the clones should be
appended.
- idMap IdMapping
- [in] A current object ID map.
- isPrimary Boolean
- [in] Flag that indicates whether this object is primary or
owned.
Return Value
DBObject
Cloned database object.
See Also