ObjectOverrule Class

This class overrules a subset of operations that an object of a database specifies. It is used as a base class for classes derived from OdDbObject to change their behavior. Each default implementation calls the corresponding method of the target class.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.RuntimeRXObject
        Teigha.RuntimeOverrule
          Teigha.DatabaseServicesObjectOverrule

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public abstract class ObjectOverrule : Overrule

The ObjectOverrule type exposes the following members.

Constructors
  Name Description
Protected method ObjectOverrule Initializes a new instance of the ObjectOverrule class
Top
Properties
  Name Description
Top
Methods
  Name Description
Public method Cancel Calls the corresponding OdDbObjectOverrule::close() method.
Public method Close Calls the corresponding OdDbObjectOverrule::close() method.
Public method DeepClone Calls the corresponding OdDbObjectOverrule::deepClone() method.
Public method Erase Calls the corresponding OdDbObjectOverrule::erase() method.
Public method Open Calls the corresponding OdDbObjectOverrule::open() method.
Public method SetCustomFilter Enables the usage of the IsApplicable method to check whether an overrule is applied.
(Overrides OverruleSetCustomFilter)
Public method SetExtensionDictionaryEntryFilter Enables the usage of an extension dictionary lookup for checking whether an overrule is applied.
(Overrides OverruleSetExtensionDictionaryEntryFilter(String))
Public method SetIdFilter Enables the usage of ID lookups for checking whether an overrule is applied.
(Overrides OverruleSetIdFilter(ObjectId))
Public method SetNoFilter Disables the filter methods (SetCustomFilter, SetExtensionDictionaryEntryFilter, SetIdFilter, SetXDataFilter) and the IsApplicable() method for checking whether an overrule is applied.
(Overrides OverruleSetNoFilter)
Public method SetXDataFilter Enables the usage of xdata for checking whether an overrule is applied.
(Overrides OverruleSetXDataFilter(String))
Public method WblockClone Calls the corresponding OdDbObjectOverrule::wblockClone() method.
Top
See Also

©  Bricsys NV. All rights reserved.