Circle(Point3d, Vector3d, Double)
Constructor
|
Constructor for the Circle class. Constructs a
full circle with its center at the specified point and radius. The
circle lies on a plane where normal is
the normal vector to the plane.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public Circle(
Point3d center,
Vector3d normal,
double radius
)
Public Sub New (
center As Point3d,
normal As Vector3d,
radius As Double
)
public:
Circle(
Point3d center,
Vector3d normal,
double radius
)
new :
center : Point3d *
normal : Vector3d *
radius : float -> Circle
Parameters
- center Point3d
- [in] Circle center.
- normal Vector3d
- [in] Normal to the plane where the circle lies.
- radius Double
- [in] Circle radius.
See Also