Point3d(PlanarEntity, Point2d)
Constructor
|
Constructor for the Point3d class. Constructs
a 3D point by the formula: p + uAxis * pnt2d.x + vAxis * pnt2d.y,
where p, uAxis, and vAxis are returned by the function call
plane.get (p, uAxis, vAxis);.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public Point3d(
PlanarEntity plane,
Point2d point
)
Public Sub New (
plane As PlanarEntity,
point As Point2d
)
public:
Point3d(
PlanarEntity^ plane,
Point2d point
)
new :
plane : PlanarEntity *
point : Point2d -> Point3d
Parameters
- plane PlanarEntity
- [in] A planar entity.
- point Point2d
- [in] 2D parameter in a plane's coordinates.
See Also