Point3d Constructor

Overload List
  Name Description
Public method Point3d(Double) Constructor for the Point3d class. Creates a new point with coordinates taken from the first three values of the passed array.
Public method Point3d(PlanarEntity, Point2d) Constructor for the Point3d class. Constructs a 3D point by the formula: p + uAxis * pnt2d.x + vAxis * pnt2d.y, where p, uAxis, and vAxis are returned by the function call plane.get (p, uAxis, vAxis);.
Public method Point3d(Double, Double, Double) Constructor for the Point3d class. Creates a new point with coordinates specified by the x, y and z values.
Top
See Also