TableSetGridLineWeight(LineWeight,
Int32, Int32) Method
|
Sets the grid lineweight for the specified
gridline types and row types in this table entity.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public virtual void SetGridLineWeight(
LineWeight lineWeight,
int borders,
int rows
)
Public Overridable Sub SetGridLineWeight (
lineWeight As LineWeight,
borders As Integer,
rows As Integer
)
public:
virtual void SetGridLineWeight(
LineWeight lineWeight,
int borders,
int rows
)
abstract SetGridLineWeight :
lineWeight : LineWeight *
borders : int *
rows : int -> unit
override SetGridLineWeight :
lineWeight : LineWeight *
borders : int *
rows : int -> unit
Parameters
- lineWeight LineWeight
- [in] Lineweight.
- borders Int32
- [in] Gridline types.
- rows Int32
- [in] Row types.
Remarks
The borders
parameter must have one of the following values:
NameValueDescriptionHorizontalTop 0x01 Top or
bottom horizontal table's grid line, depending on the flow
direction of the table rows (down or up). HorizontalInside 0x02 All
horizontal grid lines, excluding the bottom and top lines.
HorizontalBottom 0x04 Bottom or top horizontal table's grid line,
depending on the flow direction of the table rows (down or up).
VerticalLeft 0x08 The grid line at the left of the table.
VerticalInside 0x10 All vertical grid lines, excluding the left and
right lines. VerticalRight 0x20 The grid line at the right of the
table.
See Also