PlanarEntityIsPerpendicularTo(LinearEntity3d,
Tolerance) Method
|
Checks whether the specified linear entity is
perpendicular to this entity.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public bool IsPerpendicularTo(
LinearEntity3d linearEntity,
Tolerance tolerance
)
Public Function IsPerpendicularTo (
linearEntity As LinearEntity3d,
tolerance As Tolerance
) As Boolean
public:
bool IsPerpendicularTo(
LinearEntity3d^ linearEntity,
Tolerance tolerance
)
member IsPerpendicularTo :
linearEntity : LinearEntity3d *
tolerance : Tolerance -> bool
Parameters
- linearEntity LinearEntity3d
- [in] Line to test to be perpendicular to this linear
entity.
- tolerance Tolerance
- [in] Geometric tolerance.
Return Value
Boolean
Returns true if the specified line is perpendicular to this entity,
false otherwise.
See Also