LoftOptionsCheckCrossSectionCurves
Method
|
Checks whether cross section curves are valid
for the lofting operation.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public LoftOptionsCheckCurvesOut CheckCrossSectionCurves(
Entity[] crossSectionCurves,
bool displayErrorMessages
)
Public Function CheckCrossSectionCurves (
crossSectionCurves As Entity(),
displayErrorMessages As Boolean
) As LoftOptionsCheckCurvesOut
public:
LoftOptionsCheckCurvesOut^ CheckCrossSectionCurves(
array<Entity^>^ crossSectionCurves,
bool displayErrorMessages
)
member CheckCrossSectionCurves :
crossSectionCurves : Entity[] *
displayErrorMessages : bool -> LoftOptionsCheckCurvesOut
Parameters
- crossSectionCurves Entity
- [in] Array of cross-section curves.
- displayErrorMessages Boolean
- [in] Flag that specifies whether to display error messages.
Default value is false.
Return Value
LoftOptionsCheckCurvesOut
Returns the
LoftOptionsCheckCurvesOut
object that encapsulates the following data: * Flag indicating
whether all of the cross-section curves are open. * Flag indicating
whether all of the cross-section curves are closed. * Flag
indicating whether all of the cross-section curves are
planar.
Remarks
The method throws
the eInvalidInput exception if curves are
invalid.
See Also