MeshDataCollection Constructor
|
Constructor for the MeshDataCollection
structure.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public MeshDataCollection(
Point3dCollection pts,
Int32Collection faces,
EntityColorCollection colors,
ObjectIdCollection materialIds
)
Public Sub New (
pts As Point3dCollection,
faces As Int32Collection,
colors As EntityColorCollection,
materialIds As ObjectIdCollection
)
public:
MeshDataCollection(
Point3dCollection^ pts,
Int32Collection^ faces,
EntityColorCollection^ colors,
ObjectIdCollection^ materialIds
)
new :
pts : Point3dCollection *
faces : Int32Collection *
colors : EntityColorCollection *
materialIds : ObjectIdCollection -> MeshDataCollection
Parameters
- pts Point3dCollection
- [in] Array of vertices.
- faces Int32Collection
- [in] Array of faces.
- colors EntityColorCollection
- [in] Array of face colors.
- materialIds ObjectIdCollection
- [in] Array of material object identifiers.
See Also