LayoutPaperPEDrawBorder
Method
|
This method is called during vectorization to
draw the paper border.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public abstract bool DrawBorder(
Layout layout,
WorldDraw worldDraw,
Point3dCollection points
)
Public MustOverride Function DrawBorder (
layout As Layout,
worldDraw As WorldDraw,
points As Point3dCollection
) As Boolean
public:
virtual bool DrawBorder(
Layout^ layout,
WorldDraw^ worldDraw,
Point3dCollection^ points
) abstract
abstract DrawBorder :
layout : Layout *
worldDraw : WorldDraw *
points : Point3dCollection -> bool
Parameters
- layout Layout
- [in] Layout that is being vectorized.
- worldDraw WorldDraw
- [in/out] Draw object that can be used by this function to set
the necessary attributes and create the necessary geometry.
- points Point3dCollection
- [in] Collection of points that contains the four corners of the
paper.
Return Value
Boolean
true if the border is successfully drawn,
or
false if the layout uses a default
rendering of the border.
See Also