Torus(Double, Double, Point3d, Vector3d,
Vector3d, Double, Double, Double, Double) Constructor
|
Constructor for the Torus class.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public Torus(
double majorRadius,
double minorRadius,
Point3d origin,
Vector3d axisOfSymmetry,
Vector3d referenceAxis,
double startAngleU,
double endAngleU,
double startAngleV,
double endAngleV
)
Public Sub New (
majorRadius As Double,
minorRadius As Double,
origin As Point3d,
axisOfSymmetry As Vector3d,
referenceAxis As Vector3d,
startAngleU As Double,
endAngleU As Double,
startAngleV As Double,
endAngleV As Double
)
public:
Torus(
double majorRadius,
double minorRadius,
Point3d origin,
Vector3d axisOfSymmetry,
Vector3d referenceAxis,
double startAngleU,
double endAngleU,
double startAngleV,
double endAngleV
)
new :
majorRadius : float *
minorRadius : float *
origin : Point3d *
axisOfSymmetry : Vector3d *
referenceAxis : Vector3d *
startAngleU : float *
endAngleU : float *
startAngleV : float *
endAngleV : float -> Torus
Parameters
- majorRadius Double
- [in] The major *radius* of this torus. The major radius is the
distance from the origin to the center of the circular arc.
- minorRadius Double
- [in] The minor *radius* of this torus. The minor radius defines
the radius of the circular arc.
- origin Point3d
- [in] The origin of this torus.
- axisOfSymmetry Vector3d
- [in] Axis of symmetry (rotation).
- referenceAxis Vector3d
- [in] Vector that indicates the direction of the zero rotation
angle of the circular arc of this torus.
- startAngleU Double
- [in] Start angle about the axis of symmetry. Defines the lower
bound of the U parameter interval.
- endAngleU Double
- [in] End angle about the axis of symmetry. Defines the upper
bound of the U parameter interval.
- startAngleV Double
- [in] Start angle about the tube. Defines the lower bound of the
V parameter interval.
- endAngleV Double
- [in] End angle about the tube. Defines the upper bound of the V
parameter interval.
Remarks
All angles are
expressed in radians.
See Also