DatabaseWblock(ObjectIdCollection,
Point3d) Method
|
Clones the specified block table record of
this database to a new database.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public Database Wblock(
ObjectIdCollection outObjIds,
Point3d basePoint
)
Public Function Wblock (
outObjIds As ObjectIdCollection,
basePoint As Point3d
) As Database
public:
Database^ Wblock(
ObjectIdCollection^ outObjIds,
Point3d basePoint
)
member Wblock :
outObjIds : ObjectIdCollection *
basePoint : Point3d -> Database
Parameters
- outObjIds ObjectIdCollection
-
- basePoint Point3d
- [in] WCS base point for the insertion.
Return Value
Database
A handle to the cloned database.
Remarks
All objects are
cloned with their dependencies. For example, if a text entity uses
a specific textstyle, it will be copied as well.
See Also