EllipticalArc3dProjectedIntersectWith(LinearEntity3d,
Vector3d, Tolerance) Method
|
Calculates intersection points with the
specified plane according to a geometric tolerance.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public Point3d[] ProjectedIntersectWith(
LinearEntity3d line,
Vector3d projectionDirection,
Tolerance tolerance
)
Public Function ProjectedIntersectWith (
line As LinearEntity3d,
projectionDirection As Vector3d,
tolerance As Tolerance
) As Point3d()
public:
array<Point3d>^ ProjectedIntersectWith(
LinearEntity3d^ line,
Vector3d projectionDirection,
Tolerance tolerance
)
member ProjectedIntersectWith :
line : LinearEntity3d *
projectionDirection : Vector3d *
tolerance : Tolerance -> Point3d[]
Parameters
- line LinearEntity3d
- [in] A 3D linear entity with which the intersection is
calculated.
- projectionDirection Vector3d
- [in] Projection direction.
- tolerance Tolerance
- [in] Geometric tolerance.
Return Value
Point3d
If the method fails or there are no intersection points, this
method returns nullptr. The returned array consists of four
elements. Indexes: * 0 - the first intersection point on this
elliptical arc. * 1 - the second intersection point on this
elliptical arc (if it exists). * 2 - the first intersection point
on the line. * 3 - the second intersection point on the line (if it
exists).
See Also